Why Ubuntu GNOME 14.04 LTS will not be shipped with GNOME 3.12?

Hi,

Many users, for the last 5 months since the Trusty Tahr Cycle has started until now, are asking Ubuntu GNOME Team the same question over and over again. We thought to give our final, direct and clear answer for everyone.

Q: Why Ubuntu GNOME 14.04 LTS will not be shipped with GNOME 3.12?

A: Simply, because Ubuntu GNOME 14.04 LTS will be released in 17th of April, 2014 and GNOME 3.12 has been just released today. Please see the announcement of GNOME 3.12 release.

Q: So what? there is still time to introduce GNOME 3.12 into Ubuntu GNOME 14.04 LTS, right?

A: No. Because in the 20th of February, 2014 Trusty Tahr Cycle has reached to Feature Freeze:

“At this point we stop introducing new features, packages, and APIs, and concentrate on fixing bugs in the development release.”

That said, there is no time to introduce any new feature and at that time, GNOME 3.12 wasn’t yet released.

Q: But I like Ubuntu GNOME and I’d like to use it with the latest GNOME version?

A: Sure, no problem. That is why we do have our PPA.

Q: Hm, so with your PPA, can I run GNOME 3.12 with Ubuntu GNOME Trusty Tahr right now?

A: Please note that Ubuntu GNOME Trusty Tahr is ‘still’ under heavy development and testing and the main focus now is to work hard on our very first LTS release. That said, once our PPA is ready for GNOME 3.12 which has been just released today, we shall update everyone with new post on our website and all our other channels (Social Media + Mailing List). Stay tuned :)

Hope our answers will clear any confusion.

If you’re still in doubt, please Contact Us.

Thank you for choosing and using Ubuntu GNOME!

Comments are closed.